When I look at the pipeline running on a self-hosted bitbucket runner I see this log on the Docker tab:
cat: can't open '/proc/net/arp_tables_names': No such file or directory iptables v1.8.10 (nf_tables) time="2025-02-17T15:53:44.002851089Z" level=warning msg="Binding to IP address without --tlsverify is insecure and gives root access on this machine to everyone who has access to your network." host="tcp://0.0.0.0:2375" time="2025-02-17T15:53:44.002913139Z" level=warning msg="Binding to an IP address, even on localhost, can also give access to scripts run in a browser. Be safe out there!" host="tcp://0.0.0.0:2375" time="2025-02-17T15:53:45.064758635Z" level=warning msg="failed to load plugin io.containerd.snapshotter.v1.devmapper" error="devmapper not configured" time="2025-02-17T15:53:45.074749490Z" level=warning msg="could not use snapshotter devmapper in metadata plugin" error="devmapper not configured" time="2025-02-17T15:53:46.105151632Z" level=warning msg="Running modprobe bridge br_netfilter failed with message: ip: can't find device 'bridge'\nbridge 172032 1 br_netfilter\nstp 16384 1 bridge\nllc 16384 2 bridge,stp\nip: can't find device 'br_netfilter'\nbr_netfilter 24576 0 \nbridge 172032 1 br_netfilter\nmodprobe: can't change directory to '/lib/modules': No such file or directory\n, error: exit status 1" time="2025-02-17T15:53:47.654207153Z" level=warning msg="WARNING: API is accessible on http://0.0.0.0:2375 without encryption.\n Access to the remote API is equivalent to root access on the host. Refer\n to the 'Docker daemon attack surface' section in the documentation for\n more information: https://docs.docker.com/go/attack-surface/" time="2025-02-17T15:53:47.654257691Z" level=warning msg="WARNING: bridge-nf-call-iptables is disabled" time="2025-02-17T15:53:47.654266133Z" level=warning msg="WARNING: bridge-nf-call-ip6tables is disabled"
Should I worry, or is it safe to ignore these warnings?