On my self hosted runner, I am running a pipeline that consists of several steps. I noticed that the steps are randomly executed on different runners running on different servers.
But I want to run the entire pipeline on the same self hosted runners, otherwise it will fail due to missing dependencies from the previous steps.
How can I ensure that once a pipeline starts, all the steps are executed on the same runner?