I have my addon installed on my Jira Data Center instances and it had been working fine until I upgraded Jira version to be 9.12.14. When I am calling Jira REST APIs (eg: /rest/api/2/issue/123) with JWT token in the Authorization header, I am getting 401 responses with this error message:
"You do not have the permission to see the specified issue.\",\"Login Required\"
I am sure that I am using the correct shared secret for the addon and generating the JWT token in the correct way, otherwise I would get JWT verification errors.
Nothing else has changed. Why does it suddenly stop working? The error message kinda indicates that it is related to permission issue or Jira is not finding the Jira user associated to the addon?
What should I be looking at?
Thanks