This has been driving me crazy for a couple of weeks now. I recently upgraded Jira from 9.12.8 to 9.12.12. Ever since, if someone visits our Jira URL, it will only redirect them to the URL:8443 the first time they visit the page. On subsequent visits, the redirect doesn't work, and the page fails to load. If I go directly to the URL:8443, it loads every time without any issues.
I have compared the server.xml, web.xml, and urlrewrite.xml files from the current files from previous upgrades and everything looks good. I only copied the custom data from the old files to the same location in the new files; I did not overwrite the entire new files.
Are there any other files/settings I should be checking I may have missed? I don't remember this being an issue from previous upgrades.