We have migrated Bitbucket from Server to Cloud and now we have integrated Bitbucket Cloud with Jenkins Server.
In pipelines/automatic jobs, sometimes we get:
--no-tags --force --progress -- git@bitbucket.org:workspace/repo-name.git +refs/heads/*:refs/remotes/origin/* # timeout=10
ERROR: Timeout after 10 minutes
ERROR: Error fetching remote repo 'origin'
Credentials should be good because when rerunning the pipeline at another time the checkout succeeds.
Also, it happens when some users try to do it manually.
Right now, we only know its' happening on this repository.