Hello,
in bitbucket-pipelines.yml we have folowing configuration:
script:
- pipe: atlassian/rsync-deploy:0.11.1
variables:
USER: $USER
SERVER: $SERVER
SSH_PORT: "2244"
REMOTE_PATH: "/var/www/anthonys/web/dev/"
LOCAL_PATH: "$BITBUCKET_CLONE_DIR/next-app-anthonys/.next/standalone"
EXTRA_ARGS:
[
"--archive",
"--itemize-changes",
"--verbose",
"--human-readable",
"--update",
"--checksum",
"--no-times",
"--no-o",
"--no-g",
"--no-perms",
]
DEBUG: "true"
There must be some kind of issue with custom port 2244, because we are getting this error:
<span>+ rsync -rp --delete-after --archive --itemize-changes --verbose --human-readable --update --checksum --no-times --no-o --no-g --no-perms -e 'ssh -p 2244 -o StrictHostKeyChecking=no' /opt/atlassian/pipelines/agent/build/next-app-anthonys/.next/standalone <a href="mailto:anthonys@web.anthonys.cz" rel="noopener nofollow noreferrer" target="_blank">anthonys@web.anthonys.cz</a>:2244:/var/www/anthonys/web/dev/</span>
<span>+ tee /var/tmp/pipe-1701867898-23357</span>
<span>building file list ... done</span><span>rsync: mkdir "/home/anthonys/2244:/var/www/anthonys/web/dev" failed: No such file or directory (2)</span>
I think, that the problem is that rsync is trying to guess the target folder from here "<span><a href="mailto:anthonys@web.anthonys.cz" rel="noopener nofollow noreferrer" target="_blank">anthonys@web.anthonys.cz</a>:2244:/var/www/anthonys/web/dev/" but there is no need to have <a href="mailto:anthonys@web.anthonys.cz" rel="noopener nofollow noreferrer" target="_blank">web.anthonys.cz</a>:2244 as the port was correctly set by -p parameter</span>
<span>any thoughts?</span>