We've recently implemented hikari connection pooling to manage database connections, the tests are passing locally but in the pipeline, it is failing with error message:
<span>unexpected EOF on client connection with an open transaction</span>
<span>PostgreSQL init process complete; ready for start up.</span>
<span>2023-10-18 04:22:03.143 UTC [1] LOG: starting PostgreSQL 16.0 (Debian 16.0-1.pgdg120+1) on x86_64-pc-linux-gnu, compiled by gcc (Debian 12.2.0-14) 12.2.0, 64-bit</span><span>2023-10-18 04:22:03.143 UTC [1] LOG: listening on IPv4 address "0.0.0.0", port 5432</span><span>2023-10-18 04:22:03.143 UTC [1] LOG: listening on IPv6 address "::", port 5432</span><span>2023-10-18 04:22:03.144 UTC [1] LOG: listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"</span><span>2023-10-18 04:22:03.147 UTC [62] LOG: database system was shut down at 2023-10-18 04:22:03 UTC</span><span>2023-10-18 04:22:03.152 UTC [1] LOG: database system is ready to accept connections</span><span>2023-10-18 04:27:03.246 UTC [60] LOG: checkpoint starting: time</span><span>2023-10-18 04:27:07.625 UTC [60] LOG: checkpoint complete: wrote 44 buffers (0.3%); 0 WAL file(s) added, 0 removed, 0 recycled; write=4.115 s, sync=0.123 s, total=4.380 s; sync files=11, longest=0.123 s, average=0.012 s; distance=260 kB, estimate=260 kB; lsn=0/152BEA0, redo lsn=0/152BE68</span><span>2023-10-18 04:28:55.452 UTC [85] ERROR: relation "public.databasechangeloglock" does not exist at character 22</span><span>2023-10-18 04:28:55.452 UTC [85] STATEMENT: SELECT COUNT(*) FROM public.databasechangeloglock</span><span>2023-10-18 04:28:55.452 UTC [86] ERROR: relation "public.databasechangeloglock" does not exist at character 22</span><span>2023-10-18 04:28:55.452 UTC [86] STATEMENT: SELECT COUNT(*) FROM public.databasechangeloglock</span><span>2023-10-18 04:28:55.452 UTC [83] ERROR: relation "public.databasechangeloglock" does not exist at character 22</span><span>2023-10-18 04:28:55.452 UTC [83] STATEMENT: SELECT COUNT(*) FROM public.databasechangeloglock</span><span>2023-10-18 04:28:55.452 UTC [84] ERROR: relation "public.databasechangeloglock" does not exist at character 22</span><span>2023-10-18 04:28:55.452 UTC [84] STATEMENT: SELECT COUNT(*) FROM public.databasechangeloglock</span><span>2023-10-18 04:28:55.860 UTC [60] LOG: checkpoint starting: immediate force wait</span><span>2023-10-18 04:28:55.880 UTC [60] LOG: checkpoint complete: wrote 932 buffers (5.7%); 0 WAL file(s) added, 0 removed, 1 recycled; write=0.017 s, sync=0.003 s, total=0.021 s; sync files=302, longest=0.001 s, average=0.001 s; distance=17101 kB, estimate=17101 kB; lsn=0/25DF500, redo lsn=0/25DF4C0</span><span>2023-10-18 04:28:55.982 UTC [85] LOG: unexpected EOF on client connection with an open transaction</span>