This week in our automation, where the Actor = "Automation for Jira" is failing with this in the logs.
Never had an issue with this before.
Hi @Jill Vieregge
Have any Site Admin or Org Admin users changed the permissions for that user?
Have any Project Admin users changed access for the project, removing / altering permissions?
Kind regards,Bill
Hi there.
As far as I can tell, "Automation for Jira" is a default rule actor.
I don't think it would be affected by anything done to regular user permission schemes. I can't see it in the list of Users to check what group its in. You don't need to assign it any permissions in a project. But it has stopped being authenticated in some of our automation.
Snippet from https://support.atlassian.com/cloud-automation/docs/what-is-a-rule-actor/
Would you please post images of your complete automation rule and of the audit log details showing the rule execution that failed? Those may provide some context as it is possible that error is not focusing on the actual cause.
Case were it didn't work:
Answer from Atlassian - they revalidated that my permissions and automation rule were properly configured, so they suspected it was an index problem.
The re-Index of permissions related to the "atlassian-addons-project-access" project role is done on a daily basis automatically, however, there are scenarios where they are not executed properly and can cause an updated permission to be corrupted or outdated.
There are an undefined number of reasons this may happen in Jira, however, this problem usually happens because of double-entries in the project roles's database table, caused by a failed import or even project role creation. In those scenarios, we must enforce the re-index from our side.
After re-indexing, the automation worked.
It looks like you're new here. Sign in or register to get started.