We've recently installed the JIRA 9.9.0 on our new Windows server and configured the DNS with IIS as a reverse proxy. The project sidebar is loading fine when we use the local host as a base URL(http://localhost:8080), but the same is failing to load with the custom DNS via IIS. The below HTTP GET calls are raising Bad Request(400) error and it's preventing the sidebar to load and giving an error "We couldn't load the project sidebar. Refresh the page to try again". The issue started happening after we migrate the JIRA software from an old Windows server to a new Windows server. We've followed all the steps provided in the Atlassian article such as IIS Configurations, URL Rewrite, and Proxy Configurations but it's still failing with 400 errors.
Failing URL: https://xxx.customdns.com/s/0f324b341a73725e6c77af284f7119e3-CDN/-ew6rv8/990000/sd12uq/3173942cf55c369ec7f2e658b750bc29/_/download/contextbatch/css/jira.webresources:mentions-feature,jira.rich.editor.api,jira.rich.editor,-_super,-jira.view.issue,-jira.global,-project.issue.navigator,-atl.general,-com.atlassian.jira.jira-frontend-plugin:84,-com.atlassian.jira.plugins.jira-development-integration-plugin:0,-jira.webresources:calendar-localisation-moment/batch.css?agile_global_admin_condition=true&baseurl-check-resources=true&healthcheck-resources=true&jag=true&jaguser=true&jira.create.linked.issue=true&richediton=true
Failing URL: https://xxx.customdns.com/s/be3bff21099c255e83dc4a71281b3e99-CDN/-ew6rv8/990000/sd12uq/3173942cf55c369ec7f2e658b750bc29/_/download/contextbatch/js/jira.webresources:mentions-feature,jira.rich.editor.api,jira.rich.editor,-_super,-jira.view.issue,-jira.global,-project.issue.navigator,-atl.general,-com.atlassian.jira.jira-frontend-plugin:84,-com.atlassian.jira.plugins.jira-development-integration-plugin:0,-jira.webresources:calendar-localisation-moment/batch.js?agile_global_admin_condition=true&baseurl-check-resources=true&healthcheck-resources=true&jag=true&jaguser=true&jira.create.linked.issue=true&locale=en-AU&richediton=true
We've increased the URLSegmentLength and configured the proxy and HTTPS in the connector(Server.xml) file but nothing works. The following are the few articles that we followed to set up and configure JIRA and resolve the 400 errors but no luck.
Ref 1: https://confluence.atlassian.com/adminjiraserver072/integrating-jira-applications-with-iis-828788154.html
Ref 2: https://confluence.atlassian.com/jirakb/elements-in-jira-server-fail-to-render-with-400-bad-request-error-860033769.html
Ref 3: https://confluence.atlassian.com/jirakb/jira-users-receiving-the-error-400-bad-request-message-request-header-is-too-large-1032258616.html
There was a similar issue reported by someone in the past but there is no answer available in the post.
URL: https://community.atlassian.com/t5/Jira-Service-Management/IIS-Proxy-Issue-with-Project-Sidebar/qaq-p/1612299?utm_source=atlcomm&utm_medium=email&utm_campaign=mentions_reply&utm_content=topic
Any help or guidance on this would be greatly appreciated.
I was able to resolve this. You need to add "UrlSegmentMaxLength" value in Windows registry.
Hi @Venkat Ravichandran
While working on a similar case, the issue was related to the Reverse rewrite host in response headers parameter under the Application Request Routing configuration page on IIS.
Could you please confirm if this parameter is unchecked?
Hope it helps.
Hi @Artur Moura ,
Thank you so much for your response!
Yes, I've checked this attribute again in IIS now and can see the checkbox is already unchecked. Please refer to the screen shot below.
You are very welcome @Venkat Ravichandran
OK, this is good. Thanks for confirming it. Let's try another thing now.
On IIS, you should have UrlRewrite rules under an IIS site or an IIS server level.
Could you please confirm if you don't have any configuration applied to the server level that might be messing up with the connection?
The issue would be almost the same as mentioned in this KB.
Hi @Artur Moura
Thank you for the assistance again!
The UrlRewrite rules are currently present at IIS site level not at the server level. I've also verified the settings mentioned in the KB article and it's exactly the same. Please refer to the screen shot below.
Our Infra team had already completed their investigation and confirmed that there is nothing blocking the request from server, network and firewall policies.
Please let me know if you need any further details. Thanks in advance!
@Venkat Ravichandran @Tavon Hannah @Jord Coerse Was this issue resolved ?I am facing same issue after syncing non production from production in windows server. I am using jira dc 9.12.15 and JSM 5.12.15.
Hi @Rilwan Ahmed , Nope, We've moved to the cloud version so decomissioned the on-prem.
Same, we've been on cloud for a year. I remember it was something like a blocked connection from the reversed proxy, i'm not able to find the answer for you.
This solved the problem for us too! Thank you Rilwan!! 🙂
It looks like you're new here. Sign in or register to get started.