After following the steps in the key changes document: https://bitbucket.org/blog/ssh-host-key-changes
We can still get this error:
Warning: the ECDSA host key for 'bitbucket.org' differs from the key for the IP address '2406:da00:ff00::22c5:2ef4'
Offending key for IP in /srv/httpd/*host*/.ssh/known_hosts:6
Matching host key in /srv/httpd/*host*/.ssh/known_hosts:11
Removing the offending lines solves this for a short time. But then it returns again.
This doesn't happen if we force our git commands to use ipv4, it only happens for traffic over ipv6.
What we want to confirm is the following:
- That there isn't a key configuration issue for bitbucket over ipv6
- That nuking the entire known_hosts file will permanently solve this (this is what we're going to try the next time we encounter this).