Team,
I created a CI/CD pipeline for one of our micro service but it failed with the following error.
node:14-alpine image is used to create docker image. Moreover docker build took more than 30 minutes prior failing (it's too slow)
Error Message
Container 'docker' exceeded memory limit
Pipeline Code
pipelines:
branches:
Development:
- step:
name: Pre-requisite step
script:
- echo "No pre-requisites found"
- step:
name: Create docker image
script:
- echo "Creating docker image"
- docker build -t microservice:$BITBUCKET_BUILD_NUMBER .
services:
- docker
caches:
- docker
I referred the following URL
https://community.atlassian.com/t5/Bitbucket-questions/Container-Build-exceeded-memory-limit/qaq-p/1986822
to fix the issue but unfortunately issue is not resolved
I also tried by setting the following to increase the memory limit for docker service
definitions:
services:
docker:
memory: 2048
and tried setting size: 2x in the pipeline but all failed with the same error
Kindly let me know had I missed anything
Thanks
Sathish Kumar