I faced the above error when using self-hosted Linux Docker Runner,
I had tried to update the docker image and yet the system showed image up-to-date.
Hi @Louis and @Christof Koegler _Gaims GmbH_,
Can you try updating the image now by running
docker image pull docker-public.packages.atlassian.com/sox/atlassian/bitbucket-pipelines-runner
[Edited to remove the tag from the runner's image, so that the latest version of the image is pulled]
If you encounter the following error
docker: Error response from daemon: docker: Error response from daemon: Conflict. The container name "/runner-76b247e7-b925-5e7b-9da2-1cda14c4ff2c" is already in use by container "c3403236e3af5962ed3a9b8771561bd2021974941cc8a89a40c6c66cecb18f53". You have to remove (or rename) that container to be able to reuse that name. See 'docker run --help'.
then remove the runner first with the following command and then try to update again
docker container rm -f runner-76b247e7-b925-5e7b-9da2-1cda14c4ff2c
The issue should be resolved now. Please feel free to let me know how it goes.
Kind regards,Theodora
Same, seems to be a problem on Bitbucket's side. Most likely there was an issue with pushing the newest image to their registry.
Which version of the runner are you currently using (1.401 in my case)?
Hi @Theodora Boudale ,
Yes, it works now. Thank you!
Best regards,
Chris
That's good to hear, please feel free to reach out if you ever need anything else!
Hi @Theodora Boudale
Could you please let me know where the docker command I need to run Is it in my yml file? or do we need admin access to run the run the docker command
For anyone who is looking for an updated image, Ive used this one:
image: docker-public.packages.atlassian.com/sox/atlassian/bitbucket-pipelines-runner:3.11.0
Thank you, Rafael. I updated the the command in my previous answer and removed the tag from the image. This way the latest version of the runner's image will be pulled.
It looks like you're new here. Sign in or register to get started.