Using the aws-ecs-deploy-1.6.2, I keep getting an error stating:
<span>✖ Failed to update the stack.</span>
<span>An error occurred (InvalidParameterException) when calling the UpdateService operation: portName(whatsours-stripe-service-8095-tcp) does not refer to any named PortMapping in the container definitions.</span>
This is due to the fact that we had to add PortMapping name to our task definitions in AWS ECS because we want to enable client/server Service Discovery; however, our task-definition-development.json file doesn't allow us to add name in the portMappings. If we add it, then we receive the following error:
<span>✖ ECS task definition parameter validation error: </span>
<span>Parameter validation failed:</span>
<span>Unknown parameter in containerDefinitions[0].portMappings[0]: "name", must be one of: containerPort, hostPort, protocol</span>
Any solutions?