Hello All,
I've configured a Webhook in Bitbucket to integrate with Jenkins.
All the requests fail with 502.
I've added a photo.
Please help in that.
This an example of One request:
Hi @Mohamed Alaa Awaden and welcome to the community!
I believe the issue is with the webhook URL, jenkins-prod does not seem to be a public domain name but an internal one that you use to access Jenkins from your local network.
You need to use a public domain name that is accessible from the internet or from the IP addresses we use for webhook delivery. In case the server where Jenkins is installed is behind a firewall, you will also need to whitelist the following IP addresses("Outgoing Connections") that are used for webhook delivery:
Kind regards,Theodora
Hello Theodora,
I found out the root cause. It's because our jenkins machine is not on the cloud.
I've used "Polling SCM" in Jenkins instead to have Triggering in place.
Hi @Mohamed Alaa Awaden ,
Can you please elborate more about he rrot cause of your issue?
I'm also getting same error and unable to resolve it since last week
It looks like you're new here. Sign in or register to get started.