Hello! We have a strange problem in production: there are several sites, each with its own bitbucket webhook processing script. We create a standard webhook of the form https://site.com/?token=1234 on some sites Bitbucket quietly throws a request and the script works out. but there are several to which bitbucket cannot send a request and instead we get an error in its logs "Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect." while the site settings are identical to those to which the request comes. There is no authorization, https validation in the hook settings is disabled and the window goes through the webhook url through the browser. But the request does not go from the bucket dying to squid 403. Tell me where to dig?
Hi @6elkir and welcome to the community.
Is the webhook URL accessible from the internet or only from your network?
The IP addresses listed on the page below (in Outgoing Connections) are used for webhooks delivery and need to be whitelisted:
The issue most likely has to do with access control policies, proxy configuration, or firewall rules.
Kind regards,Theodora
the hook is public. deployed on 16 different sites, all sites on 1 server (differences only in the domain name). does not allow for some. moreover, the error is from the side of the internal bitbucket squid server, judging by the text
Hi @6elkir,
Could you please provide the following info so I can check logs from our side:
1) *ond******team -> yii2 -> ******72 | tam*****zal.ru | test*****y.ru2) *ond******team -> yii2 -> e****24.ru3) one|two (if have test site) hooks per repo4) last week. there were no errors on the working projects, and where there were, there was no successful operation. Feeling like bitbucket banned certain addresses and the hook always returns 403 from them
It looks like you're new here. Sign in or register to get started.