We recently changed from using only an Internal User Directory to an Active Directory User Directory, now we have users that are emailing a Service Portal but not all the emails are being processed, some are showing an error in the logs that read:
username : A user with that username already exists.
Our setup:
In AD our team has our own OU (lets call it A-Team), inside of that OU we have another OU for only our groups (lets call that A-Groups), and we have a single group called jira-users.
So our User Directory looks like:
- Base DN: DC=someorg.net
- Additional User DN: OU=Users (We need all active users available to our user select lists)
- Additional Group DN: OU=A-Team,OU=A-Groups
This is working well for provisioning users.
The problem lies when we have active employees email JSM (obviously all employees are in AD and have been brought down to Jira).
Look at these scenarios:
- If the employee is in AD, has a Jira license, has never logged into Jira the email is refused (username : A user with that username already exists.)
- If the employee is in AD, has a Jira license, has logged into Jira once the email is processed as expected.
- If the employee is in AD, does not have a Jira license, and has never logged into Jira the email is refused (username : A user with that username already exists.)
We need every employee to be able to email the Portal and create issues, can anyone tell me where we made our mistake?
Also, the only names that are appearing in our User Select List are employees that have logged in, the other users that are in AD but not jira-users group are not appearing in the select list.