I've just updated my local self-hosted pipeline, after running into some issues with Docker pull rate limits.
The pull rate limits seem to have been solved, but now the new self-hosted pipeline is throwing this error when I try to build a project:
Status 404: {"message":"No such image: docker-public.packages.atlassian.com/sox/atlassian/bitbucket-pipelines-dvcs-tools:prod-stable"}