Running a pipeline in a self hosted runner, attempting to ssh fails with:
<span>Load key "/tmp/d79ce54a-d006-572e-9d3b-7e5575164e2c/ssh/id_rsa": invalid format</span>
SSH fails to load the key. Tried different versions of openssh.
Running the same step via standard runner works as expected.