hello,
the pipeline can't reach artifactory while using a token.
JF_ARTIFACTORY_1 is a secret and is set to the token generated on a local machine by running "jf c export". The jfrog cli is from jfrog-cli-v2-jf-2.10.1-1.x86_64 rpm.
pipeline code:
push: &pushname: Push to Jfrogscript: - apk add curl - pipe: jfrog/jfrog-setup-cli:1.0.0 - source ./jfrog-setup-cli.sh - jf rt ping - jfrog rt ping --url https://XXXX.jfrog.io/artifactory --user xxxx --password xxx
jfrog rt ping - fails with 404
jfrog rt ping --url - completes with "OK"
jf rt ping on a local machine returns "OK" too.
Update:
Downgrading the cli to 1.52 did not resolve the problem with the pipeline:
jfrog-cli-1.52.0-1.x86_64jfrog -vjfrog version 1.52.0[aa@fedora utils]$ jfrog rt pingOK
the token generated by cli v1 and v2 is identical.
Update 2:
setting repository variable :
<span>Downloading version 1.9.0 of JFrog CLI...</span><span> % Total % Received % Xferd Average Speed Time Time Time Current</span><span> Dload Upload Total Spent Left Speed</span><span> 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0</span><span> 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0</span><span> 75 12.7M 75 9906k 0 0 12.8M 0 --:--:-- --:--:-- --:--:-- 12.8M</span><span>100 12.7M 100 12.7M 0 0 16.4M 0 --:--:-- --:--:-- --:--:-- 170M</span><span>bash: /usr/bin/jfrog: No such file or directory</span><span>+ source ./jfrog-setup-cli.sh</span>
<span>Downloading version 1.9.0 of JFrog CLI...</span>
<span> % Total % Received % Xferd Average Speed Time Time Time Current</span>
<span> Dload Upload Total Spent Left Speed</span>
<span> 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0</span>
<span> 75 12.7M 75 9906k 0 0 12.8M 0 --:--:-- --:--:-- --:--:-- 12.8M</span>
<span>100 12.7M 100 12.7M 0 0 16.4M 0 --:--:-- --:--:-- --:--:-- 170M</span>
<span>bash: /usr/bin/jfrog: No such file or directory</span>
Hi @Andrew Zyman
Welcome to the Community!!
You either need to use an admin token in order to have the integration or the general account encrypted password in order to authenticate while you are using jfrog cli command
Thanks,Pramodh
@Pramodh M
thank you for the reply.
> .. admin token in order to have the integration or the general account encrypted password
what is the admin token?
what is the "general account"?
Admin token reference here
https://www.jfrog.com/confluence/display/JFROG/Access+Tokens#AccessTokens-GeneratingAdminTokens
A general account is the one that you create as the service user in order to have the integration between different tools
Pramodh,
thank you. This is helpful.
To clarify:
a. pinging from a local machine - works. I can ping using user/pass or using stored configuration.
b. pinging from pipe when user/pass is used - works
c. ping is failing from the pipe when the token generated on the local machine is used.
Now. I generated an admin user token :
Username XXXScope applied-permissions/admin api:*Audience *@*Expires In 3600 Seconds
I replaced the one in JF_ARTIFACTORY_1 with this admin token.
the new error:
source ./jfrog-setup-cli.sh+ source ./jfrog-setup-cli.shDownloading version 1.37.1 of JFrog CLI...% Total % Received % Xferd Average Speed Time Time Time CurrentDload Upload Total Spent Left Speed0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 00 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 00 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0100 19.0M 100 19.0M 0 0 19.9M 0 --:--:-- --:--:-- --:--:-- 19.9M[Error] illegal base64 data at input byte 119
this is the same issue as mentioned in the still open ticket here (https://bitbucket.org/jfrog/jfrog-setup-cli/issues/6/problem-downloading-v1371-and-running)
Please advise.
It looks like you're new here. Sign in or register to get started.