So I attempted an updated of JIRA from 8.18.0 to 8.20.1 in response to CVE-2021-42574
It ended with me not being able to connect to the database and having to revert to the volume snapshot I made.
Has anyone had any luck with the this type of upgrade? I can't imagine it's too rare to be using MySQL.
Methodology
- Performed Snapshots/Backups (experience has proven this is necessary because JIRA seems intentionally difficult to adminster)
- Wget, chmod and execute script.
- Seems to run okay with no errors
- Apply changes manually (since this is still a thing duh) to conf/server.xml
- Start JIRA
Get:
Database: We've found an error in MySQL supported version!
The database type in your dbconfig.xml is set up to MySQL 5.7 and your MySQL version is different. Consider using MySQL 5.7 database type instead
See our documentation for more information on changing database type.
Applied these changes to dbconfig.xml:
- Add "&sessionVariables=default_storage_engine=InnoDB" to url connection string
- Change <database-type>mysql57</database-type> to <database-type>mysql</database-type>
That error goes away.
Also getting:
Database: JIRA couldn't connect to your database
JIRA failed to establish a connection to your database.
This could be because:
-Your database isn't running
-The configuration of your dbconfig.xml file is incorrect (user, password, or database URL etc.)
-There is a network issue between JIRA and your database (e.g. firewall, database doesn't allow remote access etc.)
There are several other solutions you can try, review our documentation and see what works for you."
Get this garbage in the log:
The last packet successfully received from the server was 26 milliseconds ago. The last packet sent successfully to the server was 22 milliseconds ago.
2021-11-02 11:16:34,110-0400 JIRA-Bootstrap ERROR [c.a.jira.health.HealthChecks] JIRA failed to establish a connection to your database.
Attempted fixes:
- Upgrade Java from 1.7 to 1.8
- Update JDBC driver to 5.49
Still getting the connection error.
We run Confluence on the same instance and it had no db connection issues.
Server is MySQL 5.7.33 running on Amazon RDS. We run JIRA on Amazon Linux AMI.
Unable to resolve.
Exceeded maintenance window by an hour and had to revert and continue to run unsafe software.
Whole morning wasted. Thanks Atlassian!