Yesterday I tried to login into my new company's e-mail but Atlassian refused to sent the invite e-mail even if trying a couple times. The only way I got logged in was using the slack account but it only works for Jira. Now, even if I own a BitBucket account with company's e-mail, the admin can't invite me to the workspace because it's necessary send an invite e-mail but it not work.
I read some posts from this community yesterday and I think my e-mail got in the "blocked list", I mean, the list with the bounced e-mails. Could you please remove my e-mail from this blocked list?