I have a public docker image which has redis and maven. My Junit testcases access redis-server via unix domain socket. This image has been working fine on gitlab pipeline for more than 1 yr now.
Today I started setting up a pipeline on bitbucket and for some reason my tests now fail with
"Failed connecting to /var/run/redis/redis.sock"
...
Caused by: java.net.SocketException: No such file or directory
The same docker image I can pull and check locally via redis-cli that it can connect to redis-server via the same UDS.
So in a nutshell
-works on locally running docker
-works on gitlab pipeline
-does not work with bitbucket pipeline.
Does bitbucket pipeline launches these dockers in a special manner that applications do not see anything outside home directory ?
Any known work arrounds... I guess I can test with localhost:6379 but that leaves a bad taste.