Pipeline version: atlassian/aws-elasticbeanstalk-deploy:1.0.0
Using version 1.0.0 of the pipeline results in error when trying to publish to an elastic beanstalk which is of type worker environment.I suppose that the error is due to worker environments do not have a CNAME.If I use version 0.8.0, I don't get an error.
Web server environments work on both versions.
Version 1.0.0
Version 0.8.0
Hi @Breno
Thank you for your question!
Yep, it looks like a bug. We'll fix it and release a new version and notify you.
Best regards,Oleksandr Kyrdan
The new version with fix released:
script: - pipe: atlassian/aws-elasticbeanstalk-deploy:1.0.1 variables: AWS_ACCESS_KEY_ID: $AWS_ACCESS_KEY_ID AWS_SECRET_ACCESS_KEY: $AWS_SECRET_ACCESS_KEY AWS_DEFAULT_REGION: 'us-east-1' APPLICATION_NAME: 'my-app-name' ENVIRONMENT_NAME: 'production' ZIP_FILE: 'application.zip'
Welcome to share your feedback!
Cheers,Oleksandr Kyrdan
I've already tested it and it's working like a charm.
Thank you.
It looks like you're new here. Sign in or register to get started.