For one of my customers, we need a dev instance in cloud for testing purposes.
Daily we're backupping the production instance which is also in cloud.
When we've tried to restore the backup on dev, it could not be done because the backup has exceeded the maximum size. Atlassian support can also not help us with restoring. They only restore data on production instance if the problem is caused by Atlassian.
Also when we would ask them to restore data on production, this will probably take at least 24h till the restore is done. That means customer will lose data between the request time and the execution time of the restore. This seems an organization risk and a no-go for the customer to continue working with Atlassian tools.
What is the best practices to protect data??
I'm sure there will be others who has experienced the same problem. Any idea would be helpful.
Thank you in advance.