Jira 8.16
For the workaround you have specified in bug Jira Server and Data CenterJRASERVER-72278
Deleting custom field gives "Data Center License Required' error
Workaround instructions
In order to pass Data Center license check, creating a cluster.properties file with a jira.node.id and jira.shared.home resolved the issue. Because of the new shared home folder, Jira software installation was needed.
Question does that jira.shared.home directory have to exist in order for this workaround to work