Currently when I go to Projects > Support > Project Settings > People and click Add people I get an error telling me that the person couldn't be added because I've reached the maximum number of users for my plan and that I should upgrade. The problem is that I've attempted to add the email address (person) as a Service Desk Customer. This gets done automatically when a customer sends a support request and including the Service Desk Customers there are already more than 10 in the current "People", so that's telling me that Service Desk Customers doesn't count against the limit when it adds them through email, but it does count against the limit here.