As part of the pipeline I want to check the kubernetes deployment scripts for syntax errors. I am adding the --dry-run=client (or just --dry-run) to the deploy command. But that seems to be ignored and the script gets executed as it were called without --dry-run.
The pipeline is defined as below:
- pipe: atlassian/aws-eks-kubectl-run:1.4.1
variables:
AWS_ACCESS_KEY_ID: "$AWS_DEV_ACCESS_KEY_ID"
AWS_SECRET_ACCESS_KEY: "$AWS_DEV_SECRET_ACCESS_KEY"
AWS_DEFAULT_REGION: "$AWS_DEV_DEFAULT_REGION"
CLUSTER_NAME: "$AWS_CLUSTER_NAME"
KUBECTL_COMMAND: "apply"
RESOURCE_PATH: "k8s/deploy/aws-dev"
KUBECTL_ARGS: "--dry-run=client"
KUBECTL_APPLY_ARGS: "-k"
How can I achieve that behavior?