Hi,
Here is my pipeline configuration
- step:
name: Deploy to production
deployment: production
image: atlassian/default-image:2
script:
- pipe: atlassian/aws-elasticbeanstalk-deploy:0.6.7
variables:
AWS_ACCESS_KEY_ID: $AWS_ACCESS_KEY_ID
AWS_SECRET_ACCESS_KEY: $AWS_SECRET_ACCESS_KEY
AWS_DEFAULT_REGION: "us-east-1"
APPLICATION_NAME: "appname"
ENVIRONMENT_NAME: "production"
S3_BUCKET: "elasticbeanstalk-us-east-1-bucketid"
ZIP_FILE: "application.zip"
VERSION_LABEL: "deploy-appname-$BITBUCKET_BUILD_NUMBER-bitbucket"
I can see the uploaded file in my S3 Bucket, however, it seems it won't link to the application. If I go to Elasticbeanstalk --> Application Versions, it isn't present.
Also, the pipeline fails with this error :
An error occurred (InvalidParameterValue) when calling the UpdateEnvironment operation: No Application Version named 'deploy-appname-63-bitbucket' found
Thank you