We moved our JIRA-, Confluence- and Crowd-starter instances to a new server (applications only, DB remainded the same).
We copied all install- and home-folders with the correct users and started the applications. Crowd and Confluence started up with no problems.
But JIRA had this entry in the startup logs and didn't start:
JIRA-Bootstrap FATAL [c.a.jira.startup.JiraStartupLogger] Startup check failed. Jira will be locked.
I found this in the Knowledge base, but the home-directory is still the same /atlassian/application-data/jira as on the previous server.