We receive emails from mainly one domain: @examplecustomer.com, which is on our allow list.
Most emails are received OK, but there's one specific email (service.desk@examplecustomer.com) where the email is rejected and we receive the "The message was rejected because it is auto-reply mail" error.
I'm told this is because the email sent from "service.desk@examplecustomer.com" is being configured with the header Auto-Submitted: auto-generated, so it's being filtered by the email handlers of Jira even though the domain is on our allow list.
Emails from service.desk@examplecustomer.com with a blank/different header work fine.
I would like this not to happen please. I don't want to have to ask our customer to change their header settings just on our account, especially if the domain should be on the allow list.
Any help appreciated. Thanks