After purchasing the JIRA license for another year I went to apply the license, but when I entered my Server ID that is displayed in my JIRA instance: 138bc530-8993-47c5-8f44-aa16497ee259 I get the error Invalid Server ID.
I made sure the SEN number in my License page on the atlassain website matched up to my JIRA instance. My SEN number is SEN-14800202
Not sure what happen to this instance as all other Atlassain products were renewed successfully.
I have 7 days left before the license is expired. Would be great to get this resolved as quickly as possible! Thanks!