We recently switched our email provider from Gmail to a hosted Microsoft Exchange environment. Since that change, incoming request to help@ourdomain.com and support@ourdomain.com are rejected with the 'The message was rejected because it is auto-reply mail' message.