Hi, I have verified my domain and it works. When i want to set up an own email address under notification Tab, I get the error: "DKIM validation failed for this domain". But the Domain has been verified by TXT DNS entry. I have read in your Support history that this is due to a bug in the Service Desk and i need to open a Ticket so you give me a workaround. Can you help me urgently?