Our MySQL version was inadvertently upgraded from 5.7 to 8. This caused our Jira server to crash. We attempted to restart the server prior to realizing the error with the MySQL version.
Once the issue was identified, MySQL 8 was removed and 5.7 was reinstalled. MySQL 5.7 would initially not start. So, the directory with jira database was copied and the original wiped out. At that point, MySQL started, and the jira database was copied back to its original location.
Currently, Jira will not start. The config file finally was wiped in an attempt to reconnect to the database, but the connection keeps getting refused. We see the log in MySQL noting this.
How do you recover when you accidentally install MySQL 8.0? Is the database corrupted beyond repair? I'm hoping someone has an easy fix for this.
Thanks,
Ashton