Our Jira Server installation stopped working yesterday, and refuses to start up. On startup it gives two error messages which don't seem to make sense in the context:
1) It says that it can't create the home directory due to permissions (but the directory exists, and updating the permissions and explicitly setting the correct Jira user does not fix this), and
2) It says there is a version mismatch between the Jira build number 801000 and the database build number 804003. Weirdly, the Jira build number is *lower* than the database number. We have not upgraded, and have certainly not downgraded Jira!!
Occasionally it allows me to get past the error screen and view the dashboard, at which point it shows "Test" in the page title, and no project data.
Most importantly, when we restore a FULL server snapshot taken from two days ago, well before the error occured, Jira still does not start, and gives the same error messages. How can it
All this leads me to believe that a) Jira has somehow decided to point at the wrong database, maybe a test database somewhere, and b) it is making that decision based on something outside of the server configuration because a full snapshot restore does not make it go away. Could it be a license key issue somehow?
How can I troubleshoot this, and what are the possible causes?