Hello,
In a cloud-jira-service-desk implementation, I have a few customers grouped into an organization.
For some reason some of them could not access, and upon some suggestions I read around I added some of them as users with no license attached. It seems it solved it for someone.
However I have this one user which gets a "no permission" page, and even if he tries by email he gets "FAILED You don't have permission to access this Service Desk." and the ticke doesn't show up.
Another strange thing, an user cannot see tickets created by someone else, even if it should be possible for them to see all requests made by their organization, correct?