I have just got myself a Jira Service Desk (free) subscription. Trying to setup the email. I've ready dozens of posts and the setup guide.
The support email account is an Office365 mailbox.
Shared mailbox was failing to authenticate with a passsword assigned.
Added a license and converted to a mailbox user account.
Microsoft account add fails to authenticate.
Other account add fails to authenticate for POP, POPs, IMAP, IMAPs.
Considered it might be due to the MFA in the tenancy. MFA is disabled on the account. Added a new app password. Still fails to auth.
Can anyone advise what needs to be done? I'm thinking this is an undocumented limitation on the free tier.