I get a HTTP2_PROTOCOL_ERROR when trying to access jira or confluence occasionally.

I noticed, that some ip-address locators are inaccurate and for example currently my ip-address is 31.29.53.24. It is the ip-address of a german provider as you can see here https://whatismyipaddress.com/ip/31.29.53.24 but resolved to Iran by other providers (e.g. https://iplocation.com/).
It is really annoying and frustrating that in such cases I need to refresh internet-connection and hope that the new IP-address is located correctly. Please update your records or completely stop messing around with ip-based geo-restrictions. Everyone knows, that such measures don't actually keep users from specific locations to actually access your services but just makes day-to-day business harder for anyone else.