Hi
First, i guess i found close to all related topics in this forum to his problem, none of them could solve my problem.
Problem:
We can't make changes in the dashboard, the google chrome console gives us a hint why not:
Failed to load resource: the server responded with a status of 500 /plugins/servlet/gadgets/dashboard-diagnostics:1
batch.js?agile_global_admin_condition=true&baseurl-check-resources=true&healthcheck-resources=true&jag=true&jaguser=true&locale=de-DE:5635 Mixed Content: The page at 'https://jira.supsign.tech/secure/Dashboard.jspa' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://jira.supsign.tech/rest/dashboards/1.0/10100/gadget/10100/color'. This request has been blocked; the content must be served over HTTPS.
Beside note, we got this error on dashboard Page to:
We've detected a potential problem with Jira's Dashboard configuration. HideClose
Dashboard Diagnostics: Mismatched URL Scheme
Configuration:
Yes, we use a ReverseProxy before a Jira and Confluence. We tried with haproxy and nginx proxy, so the proxy isn't really the problem. We tried almost everything who is written board.
The nginx.conf for this website:
server {
listen 80;
listen [::]:80;
server_name jira.supsign.tech;
return 301 https://jira.supsign.tech;
access_log /etc/nginx/logs/confluence.supsign.tech/access.log;
error_log /etc/nginx/logs/confluence.supsign.tech/error.log warn;
}
server {
listen 443 ssl;
server_name jira.supsign.tech;
ssl_certificate /etc/letsencrypt/live/jira.supsign.tech/fullchain.pem;
ssl_certificate_key /etc/letsencrypt/live/jira.supsign.tech/privkey.pem;
include /etc/letsencrypt/options-ssl-nginx.conf;
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem;
location / {
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_pass http://10.100.10.60:8080; # supsvl004
include /etc/nginx/proxy.conf;
proxy_max_temp_file_size 2048m;
add_header Strict-Transport-Security "max-age=15552000; includeSubDomains" always;
client_max_body_size 100M;
}
}The Proxy Part in server.xml
<Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^\`"<>" maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false" maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443" acceptCount="100" disableUploadTimeout="true" bindOnInit="false" secure="true" scheme="https" proxyName="jira.supsign.tech" proxyPort="443" />The Basel-Url in the Backend
https://jira.supsign.tech
Curl from the jira instance to jira himself
curl https://jira.supsign.tech - 200
curl http://jira.supsign.tech - 301
curl http://jira.supsign.tech/rest/dashboards/1.0/10100/gadget/10100/color - 405
Last funny thing, the gadgets in the backend have all still a http:// url to the xml.
I'm very thankful for every idea and hint.