We have a critical issue for the email replies. The sender of the outgoing emails is X
When a customer replies to that address, the reply is rejected by the Service Desk Auto reply filter. meaning no customer reply reaches the cloud help project. Can we have this fixed?