In my Jira Service Desk, I have a Customer Notification enabled for requests created in our email channel. We also have Confluence, and the Confluence site admin group does not get notifications when they use this channel. The email logs show that notification email fails with the following error, 
The site admins have accounts in the Project's Customers list. I can't figure out if they need an additional group membership or a special role or a specific user permission in order to receive notifications.
Any suggestions would be gratefully appreciated, thank you.