I have Jira, Confluence and BitBucket running each on own standalone Centos7 linux VM servers (latest version) . Every-time i reboot VM servers (patching linux or rebooting KVM server) the Jira and Confluence will not startup. To fix it, i have to manually restart Jira and Confluence. This happening past last year. Before i did not have this problem.
This is what i have to execute every single time after reboot VMserver to start jira
/opt/atlassian/jira/bin/shutdown.sh
/opt/atlassian/jira/bin/startup.sh
It look like i have problem with some old PID!!!!!
/var/log/messages
ay 16 12:27:35 s-jira jira: To run JIRA in the foreground, start the server with start-jira.sh -fg
May 16 12:27:35 s-jira xrdp[3928]: (3928)(140593122466240)[INFO ] listening to port 3389 on 0.0.0.0
May 16 12:27:35 s-jira systemd: Started Command Scheduler.
May 16 12:27:35 s-jira systemd: Starting Wait for Plymouth Boot Screen to Quit...
May 16 12:27:35 s-jira jira: executing using dedicated user: jira
May 16 12:27:35 s-jira postmaster: < 2019-05-16 12:27:35.861 MDT > LOG: redirecting log output to logging collector process
May 16 12:27:35 s-jira postmaster: < 2019-05-16 12:27:35.861 MDT > HINT: Future log output will appear in directory "pg_log".
May 16 12:27:35 s-jira systemd: Started GNOME Display Manager.
May 16 12:27:35 s-jira jira: `sMMMMMMMMMMMMMM+
May 16 12:27:35 s-jira jira: MMMMMMMMMMMMMM
May 16 12:27:35 s-jira jira: :sdMMMMMMMMMMM
May 16 12:27:35 s-jira jira: MMMMMM
May 16 12:27:35 s-jira jira: `sMMMMMMMMMMMMMM+ MMMMMM
May 16 12:27:35 s-jira jira: MMMMMMMMMMMMMM +MMMMM
May 16 12:27:35 s-jira jira: :sMMMMMMMMMMM MMMMM
May 16 12:27:35 s-jira jira: MMMMMM `UOJ
May 16 12:27:35 s-jira jira: `sMMMMMMMMMMMMM+ MMMMMM
May 16 12:27:35 s-jira jira: MMMMMMMMMMMMMM +MMMMM
May 16 12:27:35 s-jira jira: :sdMMMMMMMMMM MMMMM
May 16 12:27:35 s-jira jira: MMMMMM `UOJ
May 16 12:27:35 s-jira jira: MMMMMM
May 16 12:27:35 s-jira jira: +MMMMM
May 16 12:27:35 s-jira jira: MMMMM
May 16 12:27:35 s-jira jira: `UOJ
May 16 12:27:35 s-jira jira: Atlassian Jira
May 16 12:27:35 s-jira jira: Version : 8.1.0
May 16 12:27:35 s-jira systemd: Started PostgreSQL 9.6 database server.
May 16 12:27:35 s-jira jira: If you encounter issues starting or stopping JIRA, please see the Troubleshooting guide at https://docs.atlassian.com/jira/jadm-docs-081/Troubleshooting+installation
May 16 12:27:35 s-jira jira: Server startup logs are located in /opt/atlassian/jira/logs/catalina.out
May 16 12:27:35 s-jira systemd: Started Virtualization daemon.
May 16 12:27:36 s-jira jira: Existing PID file found during start.
May 16 12:27:36 s-jira jira: Unable to read PID file. Start aborted.
May 16 12:27:36 s-jira systemd: jira.service: control process exited, code=exited status=1
May 16 12:27:36 s-jira systemd: Failed to start (null).
May 16 12:27:36 s-jira systemd: Unit jira.service entered failed state.
May 16 12:27:36 s-jira systemd: jira.service failed.