Hello,
I've been trying to import a backup of Confluence Cloud taken yesterday (and one taken today) into a Server instance but it looks like there's some major incompatibilities between the Cloud and Server version. The error I got was:
Caused by: java.lang.ClassNotFoundException: com.atlassian.confluence.api.model.people.MigratedUser
Upon closer inspection of the `entities.xml` file in the backup and comparing it to a previous working one I've found some new objects not present in the old one which I believe are the cause for the import failure:
<object class="MigratedUser" package="com.atlassian.confluence.api.model.people">
<id name="key"><![CDATA[8a7f808969eb55e50169fe08f677077d]]></id>
<property name="username"><![CDATA[115e9f12d720d9675070caf292edf01f]]></property>
<property name="hashedUsername"><![CDATA[d3e5a4bb5cd842661999c9af085d7da1]]></property>
<property name="accountId"><![CDATA[12345:ab12345c-aaaa-1111-1a2b-12abcd12ab12]]></property>
</object>
It looks like the Cloud version has some username obfuscation features which are incompatible with Server. Is my understanding correct that this will not work until the next Server release? If so - when is the release expected?
Thanks,
Simon