What's the issue?
Jira installation gets interrupted with error 500.
I have tried to install 4 times with different fix attempts each time.
All resulted in error 500 and this at link: /secure/errors.jsp after refresh with blank page.
What I have done so far:
- I have modified the permissions for specified files in support articles
- I have modified the entire directories related to Jira with 777 permissions
- I have modified the environment variables for the system
- I have tried to delete tomcat cache and plugins folders from /home.
DB: MySQL
User: root w/global access to all schemes
I understand this is an issue with the installation not being able to access plugins table in the database, but since I'm using the root user I don't see any possibility of this being a permission issue.
I would appreciate any help.
Current error in full text:
2019-04-02 00:19:23 Commons Daemon procrun stdout initialized
2019-04-02 00:19:31,309 localhost-startStop-1 INFO [c.a.jira.startup.JiraHomeStartupCheck] The jira.home directory 'C:\Program Files\Atlassian\Application Data\JIRA' is validated and locked for exclusive use by this instance.
2019-04-02 00:19:31,434 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger]
****************
JIRA starting...
****************
2019-04-02 00:19:31,543 JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger]
___ Environment _____________________________
JIRA Build : 8.0.2#800010-sha1:15b32da7769637cbcbd22ae5eaacbed621a94e22
Build Date : Wed Mar 06 00:00:00 CST 2019
JIRA Installation Type : Standalone
Application Server : Apache Tomcat/8.5.35 - Servlet API 3.1
Java Version : 1.8.0_181 - Oracle Corporation
Current Working Directory : C:\Program Files\Atlassian\JIRA
Maximum Allowable Memory : 1820MB
Total Memory : 915MB
Free Memory : 856MB
Used Memory : 59MB
Memory Pool: Code Cache : Code Cache: init = 33554432(32768K) used = 11822208(11545K) committed = 33554432(32768K) max = 536870912(524288K)
Memory Pool: Metaspace : Metaspace: init = 0(0K) used = 22553888(22025K) committed = 23248896(22704K) max = -1(-1K)
Memory Pool: Compressed Class Space : Compressed Class Space: init = 0(0K) used = 2611000(2549K) committed = 2752512(2688K) max = 1073741824(1048576K)
Memory Pool: PS Eden Space : PS Eden Space: init = 100663296(98304K) used = 40963456(40003K) committed = 668467200(652800K) max = 669515776(653824K)
Memory Pool: PS Survivor Space : PS Survivor Space: init = 16777216(16384K) used = 0(0K) committed = 22544384(22016K) max = 22544384(22016K)
Memory Pool: PS Old Gen : PS Old Gen: init = 268435456(262144K) used = 20799336(20311K) committed = 268435456(262144K) max = 1431830528(1398272K)
JVM Input Arguments : -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Dorg.dom4j.factory=com.atlassian.core.xml.InterningDocumentFactory -XX:-OmitStackTraceInFastThrow -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCTimeStamps -XX:+PrintGCCause -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=5 -XX:GCLogFileSize=20M -Xloggc:C:\Program Files\Atlassian\JIRA\logs\atlassian-jira-gc-%t.log -XX:InitialCodeCacheSize=32m -XX:ReservedCodeCacheSize=512m -Dcatalina.home=C:\Program Files\Atlassian\JIRA -Dcatalina.base=C:\Program Files\Atlassian\JIRA -Dignore.endorsed.dirs=C:\Program Files\Atlassian\JIRA\endorsed -Djava.io.tmpdir=C:\Program Files\Atlassian\JIRA\temp -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=C:\Program Files\Atlassian\JIRA\conf\logging.properties exit abort -Xms384m -Xmx2048m
Java Compatibility Information : JIRA version = 8.0.2, Java Version = 1.8.0_181
___ Java System Properties ________________
// truncated due to char limit
___ Starting the JIRA Plugin System _________________
// partially truncated due to char limit
2019-04-02 00:19:40,849 JIRA-Bootstrap INFO [c.a.jira.startup.LauncherContextListener] Memory Usage:
---------------------------------------------------------------------------------
Heap memory : Used: 293 MiB. Committed: 916 MiB. Max: 2025 MiB
Non-heap memory : Used: 76 MiB. Committed: 92 MiB. Max: 1536 MiB
---------------------------------------------------------------------------------
TOTAL : Used: 370 MiB. Committed: 1007 MiB. Max: 3561 MiB
---------------------------------------------------------------------------------
2019-04-02 00:20:20,055 http-nio-8080-exec-12 INFO anonymous 20x204x1 1uftd4 0:0:0:0:0:0:0:1 /secure/SetupDatabase.jspa [c.a.j.config.database.SystemDatabaseConfigurationLoader] Storing database configuration in C:\Program Files\Atlassian\Application Data\JIRA\dbconfig.xml
2019-04-02 00:20:20,211 http-nio-8080-exec-12 INFO anonymous 20x204x1 1uftd4 0:0:0:0:0:0:0:1 /secure/SetupDatabase.jspa [c.a.j.config.database.SystemDatabaseConfigurationLoader] Reading database configuration from C:\Program Files\Atlassian\Application Data\JIRA\dbconfig.xml
2019-04-02 00:20:27,428 http-nio-8080-exec-12 INFO anonymous 20x204x1 1uftd4 0:0:0:0:0:0:0:1 /secure/SetupDatabase.jspa [c.a.jira.startup.DatabaseChecklistLauncher] JIRA database startup checks completed successfully.
2019-04-02 00:20:29,897 http-nio-8080-exec-12 INFO anonymous 20x204x1 1uftd4 0:0:0:0:0:0:0:1 /secure/SetupDatabase.jspa [c.a.j.config.database.SystemDatabaseConfigurationLoader] Reading database configuration from C:\Program Files\Atlassian\Application Data\JIRA\dbconfig.xml
2019-04-02 00:20:30,288 http-nio-8080-exec-12 ERROR anonymous 20x204x1 1uftd4 0:0:0:0:0:0:0:1 /secure/SetupDatabase.jspa [c.a.jira.startup.ComponentContainerLauncher] A fatal error occurred during initialisation. JIRA has been locked.
com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:SELECT pluginkey, pluginenabled FROM pluginstate (Table 'jira.pluginstate' doesn't exist)
at com.atlassian.jira.ofbiz.DefaultOfBizDelegator.findAll(DefaultOfBizDelegator.java:267)
at com.atlassian.jira.ofbiz.WrappingOfBizDelegator.findAll(WrappingOfBizDelegator.java:156)
at .....
// partially truncated due to char limit
......
Caused by: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:SELECT pluginkey, pluginenabled FROM pluginstate (Table 'jira.pluginstate' doesn't exist)
at org.ofbiz.core.entity.jdbc.SQLProcessor.executeQuery(SQLProcessor.java:533)
at org.ofbiz.core.entity.GenericDAO.createEntityListIterator(GenericDAO.java:877)
at org.ofbiz.core.entity.GenericDAO.selectListIteratorByCondition(GenericDAO.java:857)
at org.ofbiz.core.entity.GenericDAO.selectByAnd(GenericDAO.java:729)
at org.ofbiz.core.entity.GenericHelperDAO.findByAnd(GenericHelperDAO.java:166)
at org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:887)
at org.ofbiz.core.entity.GenericDelegator.findAll(GenericDelegator.java:797)
at com.atlassian.jira.ofbiz.DefaultOfBizDelegator.findAll(DefaultOfBizDelegator.java:265)
... 215 more
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'jira.pluginstate' doesn't exist
at sun.reflect.GeneratedConstructorAccessor55.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAcces
... // partially truncated due to char limit
Database configuration OK
___ Database Configuration ________________
Loading entityengine.xml from : file:/C:/Program%20Files/Atlassian/JIRA/atlassian-jira/WEB-INF/classes/entityengine.xml
Entity model field type name : mysql
Entity model schema name :
Database Version : MySQL - 5.6.43-log
Database Driver : MySQL Connector Java - mysql-connector-java-5.1.47 ( Revision: fe1903b1ecb4a96a917f7ed3190d80c049b1de29 )
Database URL : jdbc:mysql://address=(protocol=tcp)(host=127.0.0.1)(port=3310)/jira?useUnicode=true&characterEncoding=UTF8&sessionVariables=default_storage_engine=InnoDB
Database JDBC config : mysql jdbc:mysql://address=(protocol=tcp)(host=127.0.0.1)(port=3310)/jira?useUnicode=true&characterEncoding=UTF8&sessionVariables=default_storage_engine=InnoDB
2019-04-02 00:20:30,413 http-nio-8080-exec-12 ERROR anonymous 20x204x1 1uftd4 0:0:0:0:0:0:0:1 /secure/SetupDatabase.jspa [c.a.jira.upgrade.PluginSystemLauncher] A fatal error occured during initialisation. JIRA has been locked.
com.atlassian.jira.InfrastructureException: Error occurred while starting Plugin Manager. Unable to resolve component: interface com.atlassian.plugin.SplitStartupPluginSystemLifecycle
at com.atlassian.jira.component.pico.ComponentManager$PluginSystem.earlyStartup(ComponentManager.java:676)
at ...
// partially truncated due to char limit
... 151 more
Caused by: com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:SELECT pluginkey, pluginenabled FROM pluginstate (Table 'jira.pluginstate' doesn't exist)
at com.atlassian.jira.ofbiz.WrappingOfBizDelegator.findAll(WrappingOfBizDelegator.java:156)
... 153 more
Caused by: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while executing the following:SELECT pluginkey, pluginenabled FROM pluginstate (Table 'jira.pluginstate' doesn't exist)
at org.ofbiz.core.entity.jdbc.SQLProcessor.executeQuery(SQLProcessor.java:533)
at org.ofbiz.core.entity.GenericDAO.createEntityListIterator(GenericDAO.java:877)
at org.ofbiz.core.entity.GenericDAO.selectListIteratorByCondition(GenericDAO.java:857)
at org.ofbiz.core.entity.GenericDAO.selectByAnd(GenericDAO.java:729)
at org.ofbiz.core.entity.GenericHelperDAO.findByAnd(GenericHelperDAO.java:166)
at org.ofbiz.core.entity.GenericDelegator.findByAnd(GenericDelegator.java:887)
at org.ofbiz.core.entity.GenericDelegator.findAll(GenericDelegator.java:797)
at com.atlassian.jira.ofbiz.DefaultOfBizDelegator.findAll(DefaultOfBizDelegator.java:265)
... 212 more
Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'jira.pluginstate' doesn't exist
at sun.reflect.GeneratedConstructorAccessor55.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
at com.mysql.jdbc.Util.handleNewInstance(Util.java:425)
at com.mysql.jdbc.Util.getInstance(Util.java:408)
at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3978)
at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3914)
at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2530)
at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2683)
at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2495)
at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:1903)
at com.mysql.jdbc.PreparedStatement.executeQuery(PreparedStatement.java:2011)
at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:83)
at org.apache.commons.dbcp2.DelegatingPreparedStatement.executeQuery(DelegatingPreparedStatement.java:83)
at com.atlassian.jira.ofbiz.sql.PreparedStatementWrapper.executeQuery(PreparedStatementWrapper.java:42)
at org.ofbiz.core.entity.jdbc.SQLProcessor.executeQuery(SQLProcessor.java:527)
... 220 more
2019-04-02 00:20:35,069 http-nio-8080-exec-12 ERROR anonymous 20x204x1 1uftd4 0:0:0:0:0:0:0:1 /secure/SetupDatabase.jspa [c.a.jira.startup.DefaultJiraLauncher] JIRA has failed to start because of the following errors: [(Event: Level = (EventLevel: fatal) , Key = (EventType: startup-unexpected) , Desc = We couldn't start JIRA , Exception = An error occurred while trying to start JIRA. We can't give you any more detail right now, we suggest checking the logs for more detail and contacting our support team.<br/>See our documentation for more information on contacting our support team and creating a support zip.), (Event: Level = (EventLevel: fatal) , Key = (EventType: database) , Desc = Could not execute health check, DatabaseConfigurationManager not available. , Exception = ]