Tried again Unable to merge code due to 429 (TOO MANY REQUESTS)....
Pls let us know once server is normal.
We need to merge code to Master branch by today....
Thanks,
Ram S
Hello Ram,
Thank you for providing the error message along with the screenshot. The response 429 is typically associated with API/Request rate limiting. There are limits in place which are set per hour. Here is a break down of which rate limits are in place:
Git web (HTTPS://) requests - > 60,000 requests per hourhg web (HTTPS://) requests - > 30,000 hgweb requests per hourSSH requests (all SSH requests are rate limited) - > 30,000 SSH requests per hourAccess to raw files;Raw file requests: the number of times a file is actively downloaded, including files in the download section of the site.This is not a limit on actions such as:Pushing or pulling commitsRunning a fetch command to get recent changesPushing or pulling a branch (unless that branch contains more than 1000 new files)5,000 raw file requests per hour Archive files: .zip, .gz, and other compressed archives of your repository. - > 5,000 files per hourList a user or team's repositories (/2.0/repositories/{username}) - > 1,000 per hourList all repositories on Bitbucket (/2.0/repositories) - > 1,000 per hourList a repository's commits (/2.0/repositories/{username}/{slug}/commits) - > 1,000 per hour
Source documentation: Rate limit.
Typically waiting 1 hour from the failed response allows enough time to try again. If you’ve waited more than 1 hour and are still receiving the 429 response, please let us know.
Regards,Stephen Sifers
Thanks for your response.
We are able to merge Feature --> Develop Branch.
But we are getting above error now also for Develop --> Master branch
..../pull-requests/223/develop/diff
Thanks & Regards,
Hi Stephen Sifers,
I have declined previous one and created new pull request getting same error.
But we are getting above error now also for only for Develop --> Master branch.
New Pull request .../pull-requests/226/develop/diff
Something is causing your instance to be rate limited. This could be due to the total sum of all requests against the instance or something else that is integrated. To further find what the cause of this issue is, we request you create a support case to have someone look into this further.
To create a support request, please head over to Contact Support. When creating your request, please ensure you select the following:
When they find the issue, please share what the cause and resolution were so others may learn from this experience.
It looks like you're new here. Sign in or register to get started.