Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

sourcetree won't open


I have tried following both of the possible solutions listed on


There are no logs from it failing to open, just from the last time it successfully opened, ~ 8 hours ago.


There are no windows events either.


It just does nothing.


I am using windows 10, but I cannot check the sourcetree version, but it updated recently (in the last couple weeks).

2 answers

1 accepted

1 vote
Answer accepted

I was able to uninstall and then when I tried to install the latest version it didn't install the latest version but did install the previous version which apparently I already had but it is working now, it also didn't actually go through the install process, just opening the MSI magically opened the application, but whatever, it is working now I guess.

What version worked for you? 

For me, I just installed the latest version from the sourcetree website (3.4.9 at the time), turns out the version I had previously that worked was the latest version, so it was only "installing" the version that I already had.  At the time sourcetree suggested updating to 3.4.10 but that version wasn't actually released so it messed up the installation.

Like Anam Ahmed likes this

Maybe a failed update?

Is there a chance that SourceTree v3.4.9 told you that the 3.4.10 update available, you told it to update, but that failed?

That happened to me this morning. My solution was to go the installation directory:


There I found the directory app-3.4.10, which was empty.

Once I deleted that directory, SourceTree would start up as usual. It still prompted me to update, but I ignored it. Instead I searched this forum for a direct link to that Windows installer. That installation went smoothly.

I hope this helps someone.

This worked for me! Thank you

For a newer version this was also the solution for me

Mark West
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Apr 13, 2023

This worked! Thank you

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events