Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

sourcetree won't open

Andrew Harris October 19, 2022

I have tried following both of the possible solutions listed on https://community.atlassian.com/t5/Sourcetree-questions/Source-Tree-doesn-t-open-and-no-logs-error/qaq-p/1911763

 

There are no logs from it failing to open, just from the last time it successfully opened, ~ 8 hours ago.

 

There are no windows events either.

 

It just does nothing.

 

I am using windows 10, but I cannot check the sourcetree version, but it updated recently (in the last couple weeks).

2 answers

1 accepted

1 vote
Answer accepted
Andrew Harris October 19, 2022

I was able to uninstall and then when I tried to install the latest version it didn't install the latest version but did install the previous version which apparently I already had but it is working now, it also didn't actually go through the install process, just opening the MSI magically opened the application, but whatever, it is working now I guess.

Anam Ahmed November 15, 2022

What version worked for you? 

Andrew Harris November 15, 2022

For me, I just installed the latest version from the sourcetree website (3.4.9 at the time), turns out the version I had previously that worked was the latest version, so it was only "installing" the version that I already had.  At the time sourcetree suggested updating to 3.4.10 but that version wasn't actually released so it messed up the installation.

Like Anam Ahmed likes this
9 votes
Stew Stryker October 27, 2022

Maybe a failed update?

Is there a chance that SourceTree v3.4.9 told you that the 3.4.10 update available, you told it to update, but that failed?

That happened to me this morning. My solution was to go the installation directory:

C:\Users\<my_login>\AppData\Local\SourceTree

There I found the directory app-3.4.10, which was empty.

Once I deleted that directory, SourceTree would start up as usual. It still prompted me to update, but I ignored it. Instead I searched this forum for a direct link to that Windows installer. That installation went smoothly.

I hope this helps someone.

Max Bean
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
November 11, 2022

This worked for me! Thank you

Eric de Weerdt February 2, 2023

For a newer version this was also the solution for me

Mark West
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 13, 2023

This worked! Thank you

DavidWu
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 5, 2023

This started happening to me a couple of days ago and I checked the folder, but both app-3.4.10 and app-3.4.11 have content and I ran the SourceTree.exe inside them with no luck. So I went to the SourceTree download page and downloaded the latest version (3.4.14 at the time of writing) without uninstalling and it deleted the two folders and started 3.4.14 like nothing's wrong...

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events