SourceTree/Git stopped working (SSL related ?) Edited

Suddenly SourceTree / Git has stopped working here, I haven't done any changes.

For every repo I try to clone from GitHub I now get a "This is not a valid URL" message and this error (as an example repo, which IS a valid repo on GitHub). Also existing remote repos are not refreshed anymore (same error).

SourceTree 2.0.5.8 / embedded Git 2.62

OSX Mountain Lion

 

edit:

Seems I found the answer:

https://community.atlassian.com/t5/Sourcetree-questions/How-do-I-setup-Sourcetree-to-access-Github-now-that-they/qaq-p/735377

 

But every solution I've seen is for Windows, what do I do on Mac ?

System Git version is 2.16.2

 

PQSfvGZ

1 answer

0 votes

And you are set to use System Git instead of Embedded Git? (2.0.5.8 is no longer a supported version but we'll do our best to help)

Brian Ganninger
Senior Mac Developer, Sourcetree

Thanks for the reply.

No; I'm not set to use System Git, whichever works is fine.

So I think the question comes down to:

Which combination of SourceTree/Git

works with Mountain Lion (10.8.5, as I'm set to use this currently) and TLS 1.2, so I can access GitHub.

So, is there a solution for this (other than upgrading OS) ?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

1,230 views 4 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you