Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't log in to SourceTree during install

I'm trying to reinstall SourceTree after it became corrupted by a previous "update". It was working fine for several months before that.

I uninstalled the program and cleared everything from AppData/Atlassian, and downloaded the newest version of the installer (2.4.7).

I try to log in with my email address on the "Use an existing account" page, but nothing happens when the button is pressed, with no feedback on what is wrong.

sourcetree-broken.PNG

The "Go to My Atlassian" also doesn't work. It opens my browser, takes me to the Atlassian login page, and I can log in there, it takes me to my product licenses page, and then.... nothing happens then either. Am I supposed to download something or press a button from there? No feedback given about what I'm meant to do.

 

I see some answers about needing to use IE to log in, but this is a false. I was able to log in the first time I installed it using Chrome with no problems at all. I followed these instructions (https://community.atlassian.com/t5/Sourcetree-questions/Unable-to-login-to-atlassian-account-while-configuring-source/qaq-p/693009) anyway, which solved nothing.

I see so many similar issues around logging in/authentication while searching for an answer. This program is Big Rigs level of broken... >_>

I'm on Windows 7.

1 answer

0 votes
Ana Retamal Atlassian Team Jan 15, 2018

Hi Johnathan! I'd recommend you try a clean uninstall, to do so follow the steps:

  1. Wipe Sourcetree preferences.
  2. Uninstall Sourcetree (if it shows on the App&Features list)
  3. Backup then delete the directory below before proceeding with next step:
    • Navigate to C:\Users\<UserName>\AppData\Local and delete Sourcetree & Sourcetree-Settings folder
    • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all Sourcetree Files/ folder.
  4. Download SourceTree and install it.

Also, can you confirm if Internet Explorer is updated to the latest version?

Lastly, can you check the Sourcetree logs to see if there's any more information there?

Best regards!

Ana

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,266 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you