(internetKeychainItemForServer:withUsername:path:port:protocol:) - The specified item could not be found in the keychain.

getting this error when pushing branch from source tree to bitbucket in mac

3 answers

This widget could not be displayed.

As this is the first thing that comes up on Google when searching this error, I wanted to add the answer I found that worked when I stumbled upon this issue.

http://stackoverflow.com/questions/20217389/sourcetree-cant-push-to-bitbucket

In short: I didnt have write access to the repo.

This widget could not be displayed.

Hi Swathi,

This could be the same reason as from this post: https://answers.atlassian.com/questions/125892/submodule-with-different-user-fails-to-clone-push-with-sourcetree

In short, it might be because you're using HTTPS authentication and not specifying your username in the URL. Have a read and see if it helps.

Cheers

This widget could not be displayed.

I was getting this because the case of the username I entered was not the same as the case of the username in the URL/path. e.g. I would type username, but the repo url was https://Username@server.com:8443/path/project.git 

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

195 views 18 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you