Why won't some Issues show up on the Greenhopper board?

We have a few Issues that don't show up on our boards. We can't figure out why.

The query for the board lists the Issues.

The status of the Issue is in one of the columns.

Other Issues with the same status show up.

We're stumped -- AND we are afraid that users will miss something important.

10 answers

1 accepted

This widget could not be displayed.

Please check the filter you configured for this board. May be you should change the filter.

Raffy.

The filter is not the problem -- at least the parts of it I can see. If I run the filter and get a list of Issues, my "missing" one is in the list. Just doesn't show on the board.

Problem turned out to be that the 'Sprint' field never got a value.

This widget could not be displayed.
Are they sub tasks? If kanban, if the issues have fixversions they won't show up due to the sub query. Are they associated project/issue type for which sprint field is not valid? (in case of scrum)

Scrum board. They are not sub-tasks. No fix versions.

They match the project - and we have only one project type.

All of the other Issues in the same status, type, etc., show on the board -- as far as I can see.

  1. Re-indexing helped?
  2. Is the resolution still UNRESOLVED for that issue

@Renjith

Reindexing didn't help.

Issue is resolved, yes. But other resolved Issues still show up on the board (as they should.)

Really, resolved issues show up in the board? Is it really a scrum board?

As far as I know resolved issues should NOT show up in the board like that.

This widget could not be displayed.

Answers are quite confusing for me. I have the same problem and no idea what the reason is why listed issues friom the dependent filter aren t shown on the greenhopper board using Kanban. I tried to look for any regularities but couldn t find one.

Regards

Wolfgang

This widget could not be displayed.

Hi George,

I do have the same issue. I tried tweaking some custom fields to show/hide and different combination of settings for over an hour and I still can't make some of my issue to show in the GH Board (Scrum). I have 51 issues in one project but only 37 show on the board. Tried to find similarities among those tickets that are not showing but nothing outstands.

Could you please tell me how you fixed yours? You mentioned "'Sprint' field never got a value." What does that mean?

Thank you.

Daniel,

In order to be on a Scrum board the Issue has to be in the active sprint that the board represents. You can usually do that by switching the board view to "Plan." There you will probably find your errant Issue in the backlog or in a not-yet-active sprint.

A short cut I have used is to add the 'Sprint' field to the Issue screen, usually at the bottom of the second tab or someplace out of the way where it isn't seen. Then I can open an Issue that IS on the board, note the highest index number in that field, then edit my problem Issue and put that number into the field.

This widget could not be displayed.

I recently had this problem and this is what i found after troubleshooting the issue.

The ticket that did not show up on the board, was a ticket that was closed and then reopened in the previous sprint. eventhough the status was ready for release and should have appeared on the Done column, the ticket had the "completed in previous sprint" status under agile. That is why it did not show up in the current sprint even though it was added to the sprint during the planning session. hope that helps

This widget could not be displayed.

I have a similar problem. I have a kanban board and a scrum board based on the same filter (so I can show the whole project lifecycle, as well as just the sprint).

One (just one, as far as I can tell) issue shows up on the kanban board, but not the scrum board, and I can't figure out why. It shows up in the filter in Issue navigator, but it's nowhere on the scrum board (either in the active sprint or the backlog). This issue hasn't previously been closed and re-opened, and I can't see anything odd about it.

I've also re-indexed.

Any ideas what might be causing this?

thanks,

Mark.

This widget could not be displayed.

Same issue here, I can search it via JQL, but cann't find the issue in Scrum board. JIRA 6.1.7 & Agile 6.3.6.1.

Update: after configured the columns with statuses, the issue resolved. That's becasue we create a new status and didn't add it into any columns. At first I think it will only affect the work mode, but indeed it will also affect the plan mode.

Thanks,

Lynn

This widget could not be displayed.

Hi guys,

Have you checked if the Fix Versions field is clear? If not, please try to clear it and see if the issue starts to show up in the board once more.

 

 

This widget could not be displayed.

This can be fixed by a workaround.

Create your board from the project instead of a shared filter, after that, then modify the filter by configuring the board. Replace the project filter by your own customized fiter.

This widget could not be displayed.

You can also check the issuetype table in JIRA database, make sure the issue type has different sequence number. This is possibly the root cause.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Thursday in United States

Local Atlassian Research Workshop opportunity on Sep. 28th

We're looking for participants for another workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sh...

48 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you